blog.wansend.com

November 26, 2010

ATI HD4550 Jitter Problem fix

Filed under: General — wansend @ 7:54 pm

If you have the ATI Radeon HD 4550 Catalyst video card (HD4550) with dual monitors in Windows 7 and one of the monitors has a jitter problem, there are two ways to fix the problem.  For both fixes, you start by double-clicking on the red ATI box on the bottom task bar to bring up the Catalyst Control Center.  If it says Basic, click on the “Advanced” Button.  Select which of the two monitors has the jitter problem before trying the two methods below.

1.  The first way is quick, but not elegant.  On the top left pull-down menu select “3D”.  Below that are a bunch of modes.  Select standard.  You’ll see the 3D preview and magically the jittering stops.  Just leave that box running in the background and you’re good.

2. The second way is the long-term fix.  On the top left pull-down menu select “ATI Overdrive”.  If everything is grayed-out, click on the lock icon and click “ok” to unlock the settings.  Some people say unchecking the “Enable ATI Overdrive” will fix the problem.  For me, clicking on the Auto-Tune button changed the settings to 605 and 800 which fixed the flickering problem once and for all.

July 21, 2007

Altigen VOIP over the Internet

Filed under: Cisco — wansend @ 7:28 am

Following are notes for the Altigen Altiware OE 5.0A with Update 4 running on the Windows platform. Configuring Altigen VOIP to work over the Internet can be very tricky. Firewalls are the source of the problem on both the client and server side. Each end of the IP conversation needs to be able to independently contact the other end. If you don’t lock down ports on the server side, hackers will connect on UDP 137, 138, 139, 1026, 1027 and TCP 80, 139 and cause trouble.

Server-side solution: Take a second Cisco router that can bypass the firewall. On it you make the following tweeks:

access-list 105 remark Altigen VOIP ports allowed for route-map
access-list 105 permit tcp host 10.1.1.5 eq 10032 any
access-list 105 permit tcp host 10.1.1.5 any eq 1720
access-list 105 permit tcp host 10.1.1.5 range 49152 50152 any
access-list 105 permit udp host 10.1.1.5 range 49152 50152 any

interface Ethernet0/0
description Inside Network – to hubs. 10.1.1.1
ip policy route-map bypass-firewall

ip nat inside source static 10.1.1.5 200.200.200.5 extendable no-alias no-payload

route-map bypass-firewall permit 10
description Bypass the firewall and go directly out to the Internet
match ip address 105
set ip next-hop 200.200.200.1

Client-side Solution: Go to the website www.dd-wrt.com and find a compatible router. Go ahead and try opening up those ports on your home wifi router before going with the dd-wrt method. Upgrade the router with version v.23 SP2 or better and configure the following client-side port-forwards:

Name Port(s) TCP/UDP Destination Port(s)
AltigenPhone 10032 tcp 192.168.1.2 10032
AltigenH.225 1720 tcp 192.168.1.2 1720
AltigenH.245 49152-50152 both 192.168.1.2 same

1. Plug phone into one of my wireless router’s four ports.
2. Turn phone on and verify that it has an IP address from my DHCP server – 192.168.1.2.
3. Change phone’s server IP 200.200.200.2 via Menu > System > AW Server
4. Turn on phone’s NAT via Menu > Network > Enable NAT > Yes.
5. Register the phone via Menu > Register

May 17, 2007

Using Ping to find the largest MTU along a VPN route

Filed under: Cisco — wansend @ 11:24 pm

When a wide area network uses a VPN, additional overhead will cause packet fragmentation that can slow the network down and cause Microsoft Active Directory to grind to a halt. You can use Ping.exe and the [x+28=MTU] rule to determine the effective MTU that should be configured on the Cisco Router. MTU is the Maximum Transmittal Unit packet size. For this exercise [10.1.1.1] is the remote IP of another Microsoft box that we are going to test pings to.

1. From a Microsoft box, ping 10.1.1.1 – to make sure it is up across the VPN.

2. ping 10.1.1.1 -f -l 1473     This will show you what a failed fragment ping looks like. 1473+28=1501 which automatically gets fragmented because it is greater than 1500, the default MTU.

3. Ping 10.1.1.1 -f -l 1449     This failed for me, meaning an MTU of 1449+28=1477 wasn’t small enough.

4. Ping 10.1.1.1 -f -l 1448     This pinged successfully for me, meaning an MTU of 1448+28=1476 didn’t get fragmented – which is good. I’m looking for the largest number I can get that doesn’t fail. Now I know what MTU to configure on my VPN routers – 1476.

5. Now go to the Cisco router configuration terminal mode for the VPN interface and add the line “ip mtu 1476” or whatever number you come up with in the last step. You shouldn’t have to add the line to the Ethernet interfaces because that would squelch all of the traffic, even browser traffic that doesn’t use the VPN.

When you hold down the MTU anywhere along the line of the router path, the routers will advertise the smallest MTU as part of the TCP/UDP negotiation process. You’d think MTU discovery would be automatic, but it is only half-automatic. Still this is better than using Regedit on every computer to tweek the MTU downward.

April 18, 2007

Web Folders and OWA

Filed under: Exchange 2003 — wansend @ 4:39 am

Microsoft Outlook WebAccess and XP have an almost ready for prime time integration solution — Web Folders. To create a web folder, go into windows explorer (not IE) –>My_Network_Places –>Add_Network_Place –>Next –>Next –>paste in one of the links below –>next –>login as yourself –>next –>finish.

Next you can drag the “web folder” into your C-Drive or desktop for quick access. This can be nice for spreadsheets, word documents, and all.

Cons:

  1. You can’t map a drive to the Web Folder
  2. If you copy it to your desktop, it is just a shortcut
  3. Creating them is awkward
  4. You can’t easily create files in them by right-clicking, only from the spreadsheet
  5. The login box keeps popping up
  6. It may be slower than a mapped drive
  7. You can get to these files from the Internet – a pro and a con here
  8. If a second user opens the same file, he won’t be notified that it is already open

April 16, 2007

Exchange 2003 Mail Limits

Filed under: Exchange 2003 — wansend @ 7:21 pm

Exchange 2003 has many nooks and crannys that have to be known when you want to limit email size. Here are the four locations that I know of:

  1. Exchange SMTP
  2. Exchange Global Settings
  3. User Settings
  4. Windows 2003 Server IIS SMTP

1. Exchange SMTP. MMC–>Console_Root\Domain_(Exchange)\Administrative_Groups \MailDomain \Servers \ServerName \Protococols \SMTP \Default SMTP Virtual Server –> properties –> Messages tab. This one affects incoming message size from the Internet.

SMTP properties

2. Exchange Global Settings. MMC–>Console_Root\Domain_(Exchange)\Global_Settings\Message_Delivery –> properties –> Defaults tab. This one is applied secondly to incoming messages from the Internet. It is also the primary setting for internal mail limits. It can be overridden per user.

Global Settings

3. User Settings. MMC –>Console_Root \Active_Directory_Users_and_Computers[ad.domain.com] \domain.com \Users \Administrator –>Properties –>Exchange_General_Tab –>Delivery_Restrictions. This can be used to override the global settings for power users.

Per User Settings

4. Windows 2003 Server IIS SMTP. MMC –>Console_Root \Internet_Information_Services_(IIS6)_Manager \Windows2003Server \Default_SMTP_Virtual_Server –>properties –>Messages_tab. This was only used by me temporarily because our pop clients needed the old Mail 55 style of login that isn’t compatible with Mail2003. Our pop users used this for their outgoing mail to the corporate headquarters and out to the Internet. This is similar to the first location, but is managed in an entirely different place.

Windows 2003 Server SMTP

April 12, 2007

OWA 2003 web link redirect fix

Filed under: Exchange 2003 — wansend @ 8:30 pm

In Microsoft Outlook Web Access 2003, sometimes an email link to http://www.something.com doesn’t work. It brings up something like:

https://mail.domain.com/exchweb/bin/redir.asp?URL=http://www.something.com

Additionally, it either gives an error saying that the web page cannot be found, or a password prompt pops up.  When you try to close OWA by clicking Logoff, it also annoyingly asks for a password.

The “exchweb/bin/redir.asp” is a clue that you are now being transferred to a different part of the mail web server that has a problem with authentication.

The fix: bring up your MMC –> Internet Information Services (IIS6) Manager\mailserver\Web Sites\Default Web Site\ExchWeb –> right-click ExchWeb and select Properties –> Directory Security tab –> Authentication and access control “Edit” button –> Check the box that says “Basic Authentication” –> Fill in the default domain –> ok –> ok –> if it asks for sub-directories, Check all –> ok.

Microsoft info: http://support.microsoft.com/kb/817312

Screenshot of change:

Screen Shot

March 29, 2007

Exchange 2003 & 5.5 DST Patches

Filed under: Exchange 2003 — wansend @ 8:38 pm

All mail servers have been patched with the latest DST changes.  Workstations, however, are having a problem with calendar appointments being off by an hour for the rest of March. This Outlook 2000/2003 problem has a patch.

Description of problem: http://technet.microsoft.com/en-us/library/bb267339.aspx
Patch: tzmove.exe
Warning 1: Must already have XP/2000 DST patch for this to work (current updates)
Warning 2: Must be logged-in as an Administrator

I’ve fixed the Exchange 5.5 server on Windows 2000 Daylight Savings issue by updating it’s registry as described in http://support.microsoft.com/kb/914387

Step 1: Unzip tzupdate.zip onto a Windows 2000 PC. You must be an Administrator.
Step 2: Import global registry changes by right-clicking on Tzupdate.reg –> merge
Step 3: Run refreshTZinfo.vbs to apply the registry change locally. The script does not run verbosely.
Step 4: Verify with Regedit \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation
DaylightStart REG_BINARY 00 00 04 00 01 00… should now be 00 00 03 00 02 00…
StandardStart REG_BINARY 00 00 0a 00 05 00… should now be 00 00 0b 00 01 00…
Check that the new numbers are on the PC.  These numbers are specific to Pacific Standard Time.

I tried running the Mail third DST patch, but it is already installed with Exchange SP2.  Here’s a guide that outlines all the patches: http://exchangepedia.com/blog/2007/02/dst-2007-understanding-what-needs-to-be.html

Apparently there is a calendar bug with calendar events created a long time ago.  Each old recurring calendar event needs to be reset to a more current date for the new daylight savings time to work properly.

Exchange 2003 changing postmaster @domain1.com to @domain2.com

Filed under: Exchange 2003 — wansend @ 7:44 pm

When your active directory domain doesn’t match your email address, you have problems. One of them is that your NDR and delayed mail warnings come from postmaster@domain1.com when it should be from @domain2.com. The fix can be found in your MMC:

JerrysMMC – Console Root\DOMAIN1 (Exchange)\Recipients\Recipient Policies\Default Policy –> Properties –> E-Mail Addresses (Policy) tab –> SMTP @domain1.com Change to SMTP @domain2.com. When you click ok, it will ask you if you want to update all users. I answer No. Answering yes will change all users affected by the policy to the new domain, which can be very bad.

Even if you have other Recipient Policies, the Default Policy determines the source of NDRs.

A Google search for this topic gives unintelligible answers about event sinks or solicits third party software.

NDR = Non DeliveRable email

Lastly, if the postmaster@domain2.com email resolves as a secondary address for a user’s account, Exchange will change the email to the primary address for the user – after about a day. This can be a plus if you want to change the NDR from-address to an address other than postmaster. In my case, I had to move the postmaster@domain2.com name over to another user so it could be the primary email address.

Welcome to the Wansend.com Blog

Filed under: General — wansend @ 7:29 pm

Welcome to the wansend.com blog. This blog mostly contains technical research by Jerry Toomey relating to the following:

  • Cisco Routers
  • Cisco PIX firewall
  • Microsoft 2003 Server
  • Microsoft Exchange 2003 Server
  • Other CCIE & MCSE items
  • Banking, Housing Bubbles, LDS Church, & other personal items of interest

blog.wansend.com

Filed under: General — wansend @ 6:46 pm

Welcome to blog.wansend.com, part of www.wansend.com

Create a free website or blog at WordPress.com.